Construction de l’armoire électrique (partie 2)

Dans la première partie de cet article, je m’étais concentré sur la réalisation de la platine arrière. Dans cette seconde partie, c’est du panneau avant qu’il est question.

Le panneau avant contient les éléments avec lesquels j’interagirai. Grosso-modo, je dois pouvoir :

  • Allumer le système. J’ai choisi un interrupteur à clef pour cela.
  • Allumer les pompes. J’ai choisi des switch à deux positions.
  • Sélectionner quel corps de chauffe est actif (ou aucun des deux). Ceci est une sorte de sécurité qui m’empêche d’activer les deux corps de chauffe en même temps.  Un switch à trois position tient ce rôle.
  • Et j’avais envie d’un bouton rapidement accessible, pour diverses actions. Arrêter l’alarme, quittancer des erreurs ou des événements.
  • Et surtout, je dois pouvoir brasser. Toutes ces opérations passent par l’utilisation de l’écran tactile.

Je voulais aussi voir directement plusieurs informations :

  • Si le système est allumé. Ceci passe par une lampe.
  • La tension de la phase 1, et l’ampérage qui est tiré dessus. Grâce à deux afficheurs à 4 chiffres.
  • Si les deux pompes sont activées ou non. Grâce à des lampes témoins.
  • Si les corps de chauffe chauffent 🙂 … Encore avec des lampes.
  • Si il y a une erreur ou quelques actions à exécuter. Et çà, je veux non seulement le voir, mais aussi l’entendre… Donc une alarme.
  • Pour tout le reste, il y aura l’écran.

Une fois tous ces éléments identifiés, j’ai cherché à les disposer élégamment :IMG_0364

Puis j’ai passé quelques heures à percer des trous ronds. Ce qui est faciles car les forêts sont ronds. Et des trous rectangulaires… ce qui l’est beaucoup moins car je n’ai pas trouvé de mèches rectangulaires…IMG_0371

Donc, on doit aussi se servir de la scie sauteuse et au final on arrive à çà :IMG_0378

Ensuite, j’ai fait un coup de peinture, puis j’ai fixé les divers éléments :IMG_0383

Et enfin j’ai réalisé le câblage à l’arrière du panneau avant:IMG_0386

Il reste donc à finaliser ce boitier en assemblant toutes les parties ensemble. (Désolé pour la qualité de cette photo, une meilleure suivra…)2015-01-27 07.42.13Et là.. vos yeux avertis se demanderont ou est passé le Raspberry Pi ??? et bien il a grillé :(… Un mauvais schéma au niveau de l’électronique de mon ampèremètre l’a fait grillé. Au passage, il a envoyé 240V sur la ligne de 5V. Le Raspberry Pi na pas survécu, et en a aussi profiter pour griller l’écran 🙁

Petit contretemps donc… J’ai déjà tout racheté mais il faudra le temps que çà arrive.

 

Laisser un commentaire

Votre adresse de messagerie ne sera pas publiée. Les champs obligatoires sont indiqués avec *